介绍

BIgo围棋助理是一个围棋数据库管理程序，面向的用户是那些想提高自己的围棋水平的棋手。

BIgo围棋助理对于从15-20级到职业高段的棋手都很有帮助。

本帮助文件针对BIgo围棋助理完全版0.81，BIgo围棋助理精简版0.81和BIgo定式0.1而编写。
BIgo定式作为独立的软件发布，但集成在BIgo围棋助理完全版中。
BIgo围棋助理完全版与精简版的主要区别在两方面:
1. 棋谱和布局定式库的大小。
2. 精简版不包含BIgo定式 。

我们已努力地使BIgo围棋助理的界面简洁些。但无论如何，总是有些东西需要附加的解释。在看完这一节的概况后，选取任务中的内容就可学到如何使用程序主要功能的方法，或者阅读提示&技巧以了解BIgo围棋助理的更酷的特色。菜单和工具栏 对每个命令都有详细解释，快捷键 会让您在使用程序时更方便快捷。

这是第二版的帮助文件，仍存在一些不足，我们会很快将其完善。

我们始终欢迎您的反馈信息，如果您发现程序或文档中有任何的错误，或者有对程序有什么好的建议，请告诉我们。当我们得知有人对程序的使用有疑问时，我们会很快更新www.BIgo.ufgo.org网页上的在线帮助文件，所以，当您认为本帮助缺少您所要的信息时，请先到网站上查阅。如果您仍然需要帮助，请看技术支持。

感谢您使用BIgo围棋助理，并希望您喜欢本程序。

? 1998-2003 BIgo软件。版权所有。


数据库

BIgo围棋助理精简版和完全版的主要区别是包含数据库的大小。

BIgo围棋助理完全版数据库

BIgo围棋助理精简版数据库


完全版数据库

BIgo围棋助理完全版数据库

围棋数据库(0.81版)中收录了约108万局棋谱，它们都是业余强手(5段)、超强手(6-7段)和职业棋手(超过2万8千局，(目前有部分是匿名的，只有棋手的段位))的棋谱，棋力弱的棋手的棋谱很少。还有让子棋的棋谱。

开放式的围棋数据库建立于以下棋谱资料:

  • 布局数据库从全部的棋谱库中生成 - 约有24亿种变化。

  • 半棋盘(19x11)的布局数据库从全部的棋谱库中生成 - 超过4000亿种变化。

  • 12x12角部定式数据库从全部的棋谱库中生成 - 超过20000种变化。

  • 9x9角部定式数据库从全部的棋谱库中生成 - 超过150000亿种变化。

子库

子库是全部棋谱库的子集:

  • 职业棋手棋谱子库及布局/定式子库

  • 职业&半职业棋手棋谱子库及布局/定式子库

  • 用户自定义的子库

  • 日本、中国、韩国的最优秀棋手的个人棋谱子库及布局/定式子库:

赵治勋Cho Chikun (1383局), 曹熏铉Cho Hunhyun (1265局), 藤泽朋斋Fujisawa Hideyuki (514局), 吴清源Go Seigen (862局), 加藤正夫Kato Masao (1002局), 小林光一Kobayashi Koichi (980局), 李昌镐Lee Changho (10750局), 马晓春Ma Xiaochun (718局), 聂卫平Nie Weiping (545局), 王立诚O Rissei (510局), 林海峰Rin Kaiho (1117局), 坂田荣男Sakata Eio (731局), 武宫正树Takemiya Masaki (753局), 刘昌赫Yoo Changhyuk (815局), 大竹英雄Otake Hideo (779局) 以及其他围棋高手。

职业棋谱库的棋谱摘录于约50部中日韩的围棋年鉴、约200份围棋杂志、其它围棋出版物和Internet。。

数据库更新

数据库的内容会不断地更新。

每月更新的内容有:

  • 约1万5千到2万业余强手的棋谱(通常来自Internet的围棋服务器)。

  • 大约200-300局职业棋谱(手工录入和来自围棋网页)。


精简版数据库

BIgo 围棋助理精简版数据库

0.81版的数据库收录了24909局棋谱(其中专业棋谱2805局)。

开放式的围棋数据库建立于以下经过精简的棋谱资料:

  • 布局数据库(超过24万种变化)

  • 半棋盘(19x11)的布局数据库(约500万种变化)

  • 12x12角部定式数据库(超过430万种变化)

  • 9x9角部定式数据库(超过760万种变化)

子库

子库是全部棋谱库的子集:

  • 职业棋手棋谱子库及布局/定式子库

  • 职业&半职业棋手棋谱子库及布局/定式子库

  • 用户定制子库和棋手子库。棋手子库是最优秀棋手的个人棋谱子库及布局/定式子库:

赵治勋Cho Chikun, 曹熏铉Cho Hunhyun, 吴清源Go Seigen, 加藤正夫Kato Masao，小林光一Kobayashi Koichi, 李昌镐Lee Changho, 马晓春Ma Xiaochun，林海峰Rin Kaiho, 坂田荣男Sakata Eio, 武宫正树Takemiya Masaki.


窗口

BIgo 围棋助理主要有三类窗口:

  1. 控制面板

  2. 棋盘窗口

  3. 棋谱列表窗口


控制面板窗口

控制面板窗口包括两部分:控制面板和信息窗口

你可以将控制面板窗口拆分为两部分，通过选择菜单的视图->工具栏->'停靠信息窗' 可将它们连在一起。

菜单和工具栏对当前的活动窗口进行操作。

信息窗口显示的是棋盘上的对局信息。

对于布局和定式，信息窗显示三类统计值(如果有的话):

  1. 当前下法统计 (用于变化). 如果所选的位置可以通过不同的方法到达，程序显示当前变化的棋谱统计结果。

  2. 当前位置统计- 合计。

  3. 下一手走法统计

如果只剩下一手可以走的地方(只有唯一的返回参考点)，'下法统计'和'位置统计'结果相同，这时只显示'下法统计'。


当前下法统计

图1是对布局的当前下法统计的默认外观。

图1

前面两行显示的是下最后两手棋的最强棋手的段位(都为职业9段)。根据这些信息你就可以评估这两手棋的质量。职业9段(很可能)意味着质量高些。

研究下面的表格你会对这两手棋是好是坏有更准确的判断。

通过点击鼠标右键出来的菜单可修改查看的内容。例如，如果你选中了'显示未知结果'，将会增加一列新的数据，见图2。

图2

这是变化后的表格(图3)。

图3

可选择内容的说明

'显示百分比' - 显示/隐藏百分比值。

'显示棋谱数' - 显示/隐藏棋谱的具体数值。 前面两个必选其一。

'显示相对值'. 如果选中，未知结果的棋谱将纳入百分比的计算(图1,2)。如果未选中，这些棋谱将不参与计算(图4)。你可以比较图1(小于100%)和图4 (等于100%)的百分比值。

'显示未知结果' - 显示/隐藏未知结果的棋谱的数量

'简明显示'. 如果选中，则表中只有如图1和3的四航内容。如果未选中，则增加三行内容：'专业'，'业余段'，'入门级'(见图4)。

图4

图4显示的结果是按照图5的设定得到的。

图5

统计值中各行内容的描述

全部显示的行

  1. '职业'. 仅是职业棋手。

  2. '职业/半职业'. 职业棋手和比职业略低的棋手: 欧洲6段以上的强手。

  3. '业余强手'. 欧洲4段以上的业余棋手。

  4. '业余段'. 入段的业余棋手。

  5. '入门级'. 级水平的业余棋手。

  6. '其他'. 不知道其级别的棋手。

  7. '合计'

简明显示的行

  1. '职业/半职业'. 职业棋手和比职业略低的棋手: 欧洲6段以上的强手。

  2. '业余强手'. 欧洲4段以上的业余棋手。

  3. '其他'. 其他棋手: 低段位的，级水平的和l不知道级别的棋手。

  4. '合计'


位置统计

'位置统计'看到的内容跟'当前下法统计'的内容完全一致。

还有一点要记住的是，'位置统计'是对指定位置在所选的棋谱库的所有棋谱进行计算。


下一手走法统计

图1是'下一手走法统计'的默认外观。

红色棒图是职业棋手的下过的比率。

绿色棒图是半职业棋手的下过的比率。

蓝色棒图是其他棋手(业余强手，业余段等)的下过的比率。

图1

通过点击鼠标右键出来的菜单中的'视图'(图2)可以将棒图切换为水平的或垂直的。

图2

该菜单还能修改棋盘和图形上显示的字母的筛选次序。

图3

'第一筛选原则'

'组' - 根据实力进行分组统计

'级别' - 根据级别进行分组统计

图4

'第二筛选原则'

'总数' - 各走法的总局数

'相对的总数' - 由内建的算法计算出的各走法的局数

'胜' -

'相对的胜' - 由内建的算法计算出的各走法胜的局数


棋盘窗口

棋盘窗口可以是:

  1. 全棋盘(9x9, 13x13 和19x19)

  2. 半棋盘

  3. 棋盘的一个角

控制棋盘窗口的方法在:

菜单->示图 和

菜单 ->窗口 中有详细介绍。

在棋盘窗口上点击鼠标右键同样有这样的菜单选项:


棋谱列表窗口

有几种略有差别的棋谱列表窗口:

  1. 围棋助手数据库中的棋谱列表

  2. 外部棋谱列表

  3. 历史记录的棋谱列表

  4. 搜索出来的棋谱列表

你可以从工具->选项->列表修改各种列表的可视项。

你可以用键盘上的删除键删除当前列表中的棋谱。

在棋谱列表上选择某一棋谱，然后双击鼠标或者按'打开棋谱'按钮，就能浏览该棋谱。

通过按键Ctrl+U或菜单->工具->自动显示可以自动显示列表中的所有棋谱。

通过按键Ctrl+P或菜单->文件->打印可以打印列表中的所有棋谱。

第一种棋谱列表的列排序。

  1. 在列标题上单击鼠标左键可以对所有棋谱进行全局排序，再次单击鼠标左键可改变排序的方向。

  2. 在列标题上用Shift + 单击鼠标左键可取消当前的全局排序。

  3. 按住Ctrl键+单击鼠标左键对当前打开的列表进行局部排序。

  4. 已做过全局排序的列表，还能做局部排序。

设定全局排序后，可选择对局信息作为筛选项。

第二、三、四种棋谱列表的列排序。

这些棋谱列表作局部的列排序。在列标题上单击鼠标的左键或右键就能实现排序或取消。


菜单

本节介绍菜单的用途。这里的排列顺序与程序界面的菜单是一致的。

  • 文件

  • 棋谱库

  • 编辑

  • 视图

  • 工具

  • 窗口

  • 帮助


文件菜单

本节对文件菜单中的命令逐一说明。

打开...

打开目录...

保存

另存为...

页面设置...

打印预览...

打印...

退出


打开

文件：打开...

打开 (Ctrl+O) . 打开 SGF 文件。

如果SGF文件含有多局棋谱，程序将建立一个类似于棋谱库列表的棋谱列表。

你也可以在打开对话框中选择多个文件，所选的棋谱将出现在新建的棋谱列表中。


保存

文件: 保存

保存 (Ctrl+S). 如果当前的棋谱曾经以SGF文件保存过，该命令将对其最新修改再作保存，否则该项是禁止的。一般用 另存为 保存对局。


打开目录

文件: 打开目录...

这一功能是对 打开 的扩充。

用它可以打开目录中的所有SGF文件(包括子目录)。


另存为

文件: 另存为

另存为 (Ctrl+Alt+S).打开标准的保存对话框，可将当前的棋谱保存为新的SGF文件。


页面设置

文件: 页面设置

通过 BIgo围棋助理，你可以产生多种类型的打印输出。所有的选项分为三部分:

  • 常规

  • 谱图

  • 对局信息

另见任务: 打印。


页面设置: 常规

文件: 页面设置: 常规

'页边距'. 这一组参数设定打印纸四边的边距(以厘米为单位)。

'谱图类型'. 定义要打印的内容。

  1. 棋谱用于打印 棋谱, 棋谱集或变化

  2. 变化用于打印变化分支

  3. 位置

'谱图编号'. 在打印棋谱和变化图时有效，这些参数决定多图棋谱的编号方式。

  • '每图从1开始' 的意思是每幅图都从第一手开始重新编号

  • 'Num - 100'. 图与图间的编号是连续的，但只打印两位(没有百位数)。

  • '全部'. 连续编号。

'打印棋谱(变化图)'.

'从哪一手开始编号'. 设定从哪一手开始编号，默认是从1开始(通常用于棋谱打印)。如果你要打印一些从指定位置开始编号的谱，如变化图，将此参数设为要开始编号的那一手棋。

'打印到哪一手结束'. 设定打印到哪一手。 '0' 代表打印到棋谱的最后。打印变化或变化分支时不能让它为0 。

'最大图数' 为打印的谱图中最多有几幅图。可能会出现最大图数小于'每图手数'中设定的图数情况。

'每图手数' 决定每幅图打印几手棋，如果为空， 则将总手数除以图数。

例如:
'50;50;100' 是指第一、二幅图每图50手，其它图每图100手。
'5' 是指除了最后一幅图，其余全都是每图5手棋，而将剩下的棋都打印在最后一幅图上。
更多例子。

'用新页面打印下一局'只用于打印多局棋谱。

另见任务--打印中的各项内容。


页面设置: 谱图

文件: 页面设置: 谱图

所以参数都是仅对特定的谱图类型有效(文件->页面设置->常规->谱图类型).

'加粗边线'. 决定谱图中边线是否比其它线要粗些。

'棋盘显示字母'. 如果选中，下一手棋如何走法的提示字母将在谱图上打印出来。

'显示提子'. 如果选中，棋谱的注脚上列出提子的情况

'显示谱图标题'. 如果选中，打印'对局信息'。

'显示图号'. 如果选中，打印谱图编号。

'谱图大小(19x19)'. 设定19X19棋盘的图的大小(单位: 厘米)。

'图间距(X轴)'. 两图之间水平间距(单位: 厘米)。

'图间距(Y轴)'. 两图之间水平间距(单位: 厘米)。

'变化选项' - 打印变化分支时的附加选项。

'第一图显示手数'. 显示-隐藏初始位置棋子的编号。

'附加信息'. 在谱图标题上打印一些附件的信息(打印变化图)。


页面设置: 对局信息

文件: 页面设置: 对局信息

仅当谱图类型为"棋谱"时有效(文件->页面设置 ->常规->谱图类型)。

'显示对局信息'.

'显示简明的对局信息'. 如果选中，对局信息显示在第一幅图的上方，否则，第一幅图的位置显示对局信息。

'不可见对局信息' - '可见对局信息'

在这列表中设定需要从BIgo棋谱数据库中打印哪些内容及排列顺序。

你可以方便的选择所要的内容，随意的上下移动。


打印预览

文件: 打印预览

打印预览... 打开打印预览窗口。

这个窗口显示当前打印页的页面预览，其参数及内容由页面设置决定。

如果打印的内容超过一页，可用'上一页'和'下一页'按钮进行翻页。

还可用'缩放' 编辑框对页面进行缩放。

'页面设置' 按钮可以修改布局。

'打印' 按钮启动打印。

'关闭' 按钮关闭窗口。


文件: 打印

Print (Ctrl+P). 打开标准的打印对话框。

打印页面设置中设定的谱图，可以是一局或多局棋谱，布局或定式的变化等。


退出

文件: 退出

关闭所有窗口并结束程序运行。


棋谱库菜单

本节对棋谱库菜单中的命令逐一说明。

程序支持多种同样结构的棋谱库。

全部棋谱

职业/半职业棋谱

职业棋谱

9段高手棋谱

定制子库

棋手子库

定式项只有在BIgo围棋助理完全版可用。

历史记录


全部棋谱

你可以对'棋谱列表'进行排序, 搜索, 筛选，然后查看棋谱。

你可浏览:

  • 全棋盘布局

  • 半棋盘

  • 定式12x12

  • 定式 9x9

它们都是从棋谱数据库(精简版 或 完全版)建立的。


棋谱列表

棋谱库: 棋谱列表

打开棋谱库相应的棋谱列表。

见标题棋谱列表窗口


全棋盘布局

棋谱库: 全棋盘布局

打开棋谱库的全棋盘布局。


半棋盘布局19x11

棋谱库: 半棋盘布局19x11

打开棋谱库相应的的半棋盘布局19x11。


定式12x12

棋谱库: 定式12x12

打开棋谱库相应的局部棋盘定式12x12。


定式 9x9

棋谱库: 定式9x9

打开棋谱库相应的局部棋盘定式9x9。


职业/半职业棋手棋谱

棋谱库: 职业/半职业棋手棋谱

如果你不喜欢业余棋手的棋谱，则可以选择只有职业棋手和半职业棋手的棋谱。

见全部棋谱


职业棋手棋谱

棋谱库: 职业棋手棋谱

从这一菜单项选择的数据库仅有职业棋手棋谱。

见全部棋谱


9段高手棋谱

棋谱库: 9段高手棋谱

从这一菜单项选择的数据库仅有职业9段高手棋谱。

见全部棋谱


棋手子库

棋手子库窗口与定制子库类似。

顺便告诉你，位于字库列表右边的垂直滚动条较小，不太容易看见。

添加新的子库同样与定制子库类似。

它们的不同之处是:

  1. 没有选择按钮，因为无需选择筛选项来建立子库，只要在编辑框输入棋手的名字即可。

  2. 可以建立两个全棋盘的布局文件: 将执黑和执白分开。


定制子库

下面是最初的定制子库窗口。里面已经预定义了一些子库，可供你自己定制子库是参考。

欲打开其中的子库:

  1. 点击子库名，出现可选的子库。

  2. 选择其中一个子库。

  3. 按'打开'按钮。

要删除整个子库，先从列表中选取，再按'删除'按钮。

要删除子库的某个布局文件，先从列表中选取，再按'删除'按钮。

要添加新子库，则按'添加'按钮。

由于定制子库和棋手子库是建立在筛选项的基础上的，例如，通过筛选项选出的棋谱建立子库，就要按'选择...'按钮，再从筛选项列表中选择筛选项。本窗口不能修改筛选项的名称。

不要选中'自动建立'，然后:

  1. 选择你要建立子库的布局文件。

  2. 修改子库的路径(如果你想将它们分组，就像预定义的'Book'，只要简单的输入组名\子库名，子库建立后就会在列表中出现组名)。

  3. 修改'简短信息'编辑框的内容，这些内容将在将在子库窗口作提示用。


历史记录

棋谱库: 历史记录

历史记录 (Ctrl+Alt+H). 打开历史记录的窗口: 内容为已打开过的棋谱的列表。列表按打开时间先后排列，最后打开的棋谱排在最前。

在列表窗口上可直接修改列宽和排序。工具->选项->列表对列内容进行定义和设定历史记录保存棋谱的数量。


编辑菜单

本节对编辑菜单中的命令逐一说明。

  • 复制

  • 全选

  • 棋子

  • 在棋盘设阴影

  • 清除


复制

编辑: 复制

复制 (Ctrl+C). 如果棋盘窗口激活，则将棋盘的BMP位图复制到剪贴板。
如果棋谱列表窗口激活，则将高亮度(选中)的棋谱信息复制到剪贴板。
等等。


全选

编辑: 全选

全选 (Ctrl+A). 选择棋谱列表中的所有计录。


棋子

编辑: 棋子

这子菜单在搜索模式时启用。

添加黑棋子. 按这菜单项就可以在棋盘上摆放黑棋子，以便进行位置搜索。

添加白棋子. 按这菜单项就可以在棋盘上摆放白棋子，以便进行位置搜索。

添加黑白棋子. 按这菜单项就可以在棋盘上按顺序摆放黑白棋子，以便进行位置搜索。

添加白黑棋子. 按这菜单项就可以在棋盘上按顺序摆放白黑棋子，以便进行位置搜索。

清除棋子. 开关清除棋子模式。


在棋盘设阴影

编辑: 在棋盘设阴影

在棋盘设阴影. 本开关在搜索模式时使用。如果被按下，可用鼠标在棋盘上建立一个或多个阴影区，在位置搜索时将不包含阴影区。


清除

编辑: 清除

Clear. 本操作在 搜索模式时使用。选择它后将棋盘的内容清除，包括棋子、阴影区。


视图菜单

本节对视图菜单中的命令逐一说明。

  • 浏览

  • 棋盘

  • 互换

  • 旋转

  • 对称

  • 总在最前

  • 工具栏


浏览菜单

视图: 浏览菜单

所有的棋盘窗口(棋谱，布局，定式)都能使用下列命令

开局 (Home). 回到对局的开始或者布局/定式的最初点。

后退10手 (Left Arrow). 往后退10手。

前一节点 (Page Up). 直接去到布局/定式中的前一节点，在没有变化的对局中，将回到对局的开局。

上一手 (Left Arrow). 退回到上一手。

下一手 (Right Arrow). 对局的下一手。 在布局/定式窗口，下一手走的是默认的位置(字母'a')或者重复已经走过的变化。

下一节点 (Page Down). 直接去到布局/定式中的下一节点，在没有变化的对局中，将直接到对局的终局。

前进10手 (Left Arrow). 往前进10手。

终局 (End). 直接到当前对局的终局。

键盘: 每一命令的键盘快捷方式在上面都用斜体字。 要注意的是使用键盘快捷方式的棋盘需要取得视点。


棋盘菜单

本菜单的所有项目跟棋盘 ->选项->工具栏相应的项一致。


互换

视图: 互换

互换 (Ctrl+Alt+I) 棋盘上棋子的颜色交换。用于定式和半棋盘的布局。


旋转

视图: 旋转

'90 度' (Ctrl+R). 棋盘顺时针旋转90度。

'180 度'. 棋盘旋转180度。

'270 度s'. 棋盘反时针旋转90度。


对称

视图: 对称

水平 (Ctrl+H). 棋盘上棋子的位置以水平中线为中心作对称交换。

垂直 (Ctrl+V). 棋盘上棋子的位置以垂直中线为中心作对称交换。

对角线 \ (Ctrl+\). 棋盘上棋子的位置以对角线(从左上角到右下角)为中心作对称交换。

对角线 / (Ctrl+/). 棋盘上棋子的位置以对角线(从右上角到左下角)为中心作对称交换。


总在最前

视图: 总在最前

'总在最前'. 如果选中，则控制面板窗口总在最前显示。如果未选中，则跟正常窗口一样。


视图：工具栏

视图: 工具栏

如果想在控制面板窗口上显示某一工具栏，在这里要选中相应的选项。

实际上控制面板窗口包括两个窗口: 控制面板本身和信息窗口。可通过'信息窗停靠'将它们拆分和连接。

最后的菜单项'状态条'设定控制面板窗口是否包括状态条。当鼠标停留在工具栏或菜单上，状态条会显示所选命令的功能描述。


工具菜单

自动显示

位置搜索...

布局棋谱列表

从对局打开布局

布局分析

声音

选项...

语言


自动显示

工具: 自动显示

要免去每走一手都要点击的麻烦，可以使用自动显示模式。 只有激活的窗口才会自动显示 (如果使用自动显示模式) ，但你可以设置不同的窗口用不同的延迟时间。

自动显示 (Ctrl+U). 打开如上图的对话框。 输入延迟时间或通过滑动条设定。

按 Ctrl+U 或从菜单、工具栏中选择相应的命令就可以关闭自动显示模式。


工具: 布局分析

打开当前棋盘或棋谱列表上选定对局的布局分析窗口。

详见 任务-- 布局分析


语言

工具: 语言

更改程序界面的语言。

现在你可选的语言有:

  1. 中文

  2. 俄语

  3. 英语

为程序创建你自己的本地语言是非常容易的事情。

你只要在BIgo围棋助理的安装目录中找到文件 English.lng，将其改名为“你的语言.lng” ，将文件中的字符串翻译出来并放在 '=' 后面。

请以 Russian.lng 文件作为例子。

程序重起后，新的语言将在菜单的语言栏显示出来。


选项

选项: 目录

选项窗口的主画面。

列出BIgo数据库的目录。

一般不必改动这些选项。


选项: 棋盘

棋盘选项有三个不同的设定:

  • 程序窗口显示的棋盘

  • 导出到剪贴板上的棋盘

  • 棋盘坐标

窗口选项

棋盘 背景可以是:

  • 棋盘表面光滑(无位图)，颜色由用户设定。

  • 自己选定棋盘背景的位图文件。BIgo围棋助理的目录中已经存有几个不同的木质棋盘文件。

游戏声音. 你可以修改WAV声音文件。

开关'自动保存窗口参数'让程序自动保存棋盘的大小供以后使用。

开关'鼠标不连续移动':

  • '选中': 鼠标的光标变成十字光标，且只会在棋盘的点上移动。

  • '未选中': 鼠标的光标不变，跟往常一样移动。

状态改变后，在下一次新开的窗口起作用。

剪贴板选项

设定剪贴板的棋盘图像背景 。

棋盘坐标选项

这些选项用来设置棋盘上显示的坐标的参数，通过'显示坐标'按钮( [image]) 或菜单的'视图->棋盘->显示坐标'可控制是否显示坐标。

对应于棋盘的四条边，这里也有四组同样内容的设置: 左，右，上，下。用户可对坐标作全方位的调整。

图中的设置是选项的默认值。

选项

可见的 - 设定坐标是否可见。

反向 - 坐标的反序排列。

样式 - 设定坐标的样式。

字体 - 设置坐标字体的属性。


选项: 棋子

棋子选项有两个不同的设定:

  • 用于程序中显示的棋子

  • 用于导出到剪贴板上的棋子

这两项设置类似。

你可以将棋子设置为'无位图' - 颜色由你决定的简单的圆棋子，也可以设置为 '位图' - 黑白棋子都是位图。


选项: 对局

通过本窗口你可以从BIgo棋谱库选择当棋盘激活时在控制面板窗口中的内容，还可修改它们的排列顺序。

你可以方便地选择要包含的内容，且随意上下移动。


选项: 列表

有三种不同的列表类型:

  1. 棋谱库/子库的棋谱列表

  2. 历史记录

  3. 指定的布局/定式或位置搜索得到的棋谱列表

首先要从'棋谱列表类型'中选择要设定的类型。其它选项都是针对所选定的列表类型的。

'默认窗口大小'以像素显示。你可以修改其参数，手动调整窗口大小。

如果'自动保存窗口参数'被选中，则所有参数都保留在注册表中，供下次运行时使用。

'载入棋谱最大数'取决于计算机的内存大小。如果你的计算机不是很超级，该数值不要大于200-300。

'可见棋谱信息区列表'定义所选列表类型的显示信息和顺序。

'列宽'定义高亮(选择)信息显示的宽度。


窗口菜单

本节对窗口菜单中的命令逐一说明。

红线圈起来的是会变化的菜单，是根据所打开窗口的外观显示的窗口列表。

复制棋盘

创建研究棋盘

创建对局棋盘

下一窗口

锁定(解锁) 窗口

关闭当前窗口

关闭所有窗口


复制棋盘

复制棋盘 (Ctrl+D). 复制一个当前激活的棋盘，包括其所以的信息。


创建研究棋盘

创建研究棋盘(Ctrl+T). 复制一个当前激活的棋盘，但只有位置情况。它允许尝试不同的下法。你只能在棋盘的空白处下棋，最后的下法被保存而且能回放。


创建对局棋盘

创建对局棋盘. 目前的版本中跟创建研究棋盘类似。


下一窗口

下一窗口(Tab). 使窗口列表中的下一个窗口激活，控制面板中的信息相应切换。


关闭当前窗口

Close Active Window (Escape). 快速关闭窗口，但不能关闭已锁定的窗口，要将其关闭必须先解锁或通过关闭所有窗口来关闭。


关闭所有窗口

如果打开的窗口太多，你可以通过一次按键就能将它们全部关闭，就算是锁定的窗口也将关闭。


帮助菜单

帮助就是帮助，关于就是关于。


工具栏

本节介绍工具栏的每个按钮的作用。这里的排列顺序与程序界面的工具栏是一致的。

标准工具栏

浏览工具栏

对称工具栏

编辑工具栏

窗口工具栏

棋盘选项工具栏


标准工具栏

除了最后一个按钮，其它的都在文件菜单中有相应的说明。

打开

保存

另存为

打印 . 不打开Window的打印对话框， 立即开始打印。

锁定


锁定窗口

锁定-解锁窗口

- [image] 锁定-解锁窗口.

锁定当前活动窗口，防止按ESC键就能将其关闭。


浏览工具栏

所有按钮的功能在浏览菜单中都有解释。

对局浏览按钮。

到指定点

自动显示.


对称工具栏

共有两组按钮:

  1. 对称转换.

  2. 旋转.


编辑工具栏

所有的按钮都在编辑菜单中有相应的说明:

  • 前五个按钮在 编辑->棋子

  • 最后一个 [image] 在 编辑->在棋盘设阴影


棋盘选项工具栏

显示-隐藏当前棋盘上的坐标。

在布局/定式时，显示-隐藏下一手可能走的位置的提示字母。

显示-隐藏对称位置上的下一手的提示字母。

如果按下该按钮，下一手的提示字母将按棋手的强弱用不同的颜色显示:

  • 红色- 职业棋手,

  • 绿色-半职业棋手,

  • 军蓝色(深蓝色) - 业余强手.

过滤. 显示/隐藏少数棋手走过的位置。


布局选项工具栏

有四个定制位置统计值的按钮。

显示/隐藏所有栏目中胜的数量。

显示/隐藏所有栏目中胜的百分比。

在统计胜的百分比时 包括/不包括未知结果的对局。

显示/隐藏未知结果的对局的百分比(数量)。

这是四个按钮都按下后显示的数据表。


窗口工具栏

本节对窗口工具栏中的命令逐一说明。

历史记录

复制棋盘

研究棋盘

布局棋谱列表

搜索模式

从对局中打开布局


窗口: 布局棋谱列表

布局棋谱列表. 在布局/定式窗口激活时该键可用。创建并打开给定布局/定式的棋谱列表，如果紧有一局，则直接用棋盘打开该局棋。


窗口: 搜索模式

搜索模式(F5). 将当前的棋盘活动窗口切换到搜索模式。在布局/定式窗口(不是对局窗口)激活时该键可用。

另见: 任务-通过位置搜索。


窗口: 从对局打开布局

从对局打开布局. 程序的独特功能。当载入外来的SGF文件的窗口激活时该键可用。按完后会打开一个新的布局窗口

详见任务: 从对局打开布局.


任务

本节教你如何进行浏览布局和定式、搜索指定位置、打印谱图等BIgo任务

  1. 打印

  2. 搜索

  3. 查看

  4. 其它


打印

BIgo围棋助理可以打印出多种内容。

  1. 打印位置

  2. 打印变化: 定式或布局(半棋盘或全棋盘)。

  3. 打印棋谱在一幅或多幅图上。

  4. 打印布局/定式分支

  5. 打印多局棋谱。

通常，你最好在打印前通过打印预览检查你要打印的内容。


打印位置

这是非常简单的任务，打印当前的位置图。

页面设置->常规和页面设置->对局信息中的所有参赛都无效。

你只能设置页面设置->谱图中的参数。


打印棋谱

很多窗口都能打印棋谱:

  1. 任何棋谱列表，包括历史记录。将打印选中的棋谱，如果选择的棋谱不只一个，将打印多局棋谱。

  2. 对局棋盘窗口。将打印当前的棋谱。

  3. 布局/定式窗口。将打印全部变化图(或者所有连续的'a'，如果变化还没完)。

打印棋谱要设置如下选项:

  1. 设置页面设置->常规->谱图类型为棋谱。

  2. 设置页面设置->常规->从哪一手开始编号为1。

  3. 设置页面设置->常规->打印到哪一手结束为0(如果你想打印全部)或者将此值设置为你想打印到的位置。

  4. 根据你的需要设置页面设置->常规->谱图编号。

  5. 在页面设置->常规->最大图数中设定要将棋谱分成几幅图打印。

  6. 设置 页面设置->常规->每图手数。

  7. 在页面设置->谱图中设定图的大小等内容。

  8. 在页面设置->对局信息中要打印的对局信息及排列顺序。


打印多局棋谱

程序中的所以列表窗口都允许有多个选择。

因此，你可以从列表中选择多局棋谱来打印。

所有页面设置选项对每局棋谱都有用。

针对'打印多局棋谱'的唯一选项是: 页面设置->常规->'用新页面打印下一局'。

更多信息另见打印棋谱。


打印变化图

实际上，这是棋谱打印中的一部分内容。

如果你仅想打印布局/定式中的一种变化或者棋谱中的部分内容，则:

  1. 设置页面设置->常规->谱图类型为棋谱。

  2. 设置页面设置->常规->从哪一手开始编号为你想在图中第几手开始编号(例中为6)。

  3. 设置页面设置->常规->打印到哪一手结束为变化结束处(例中为19)。

  4. 设置页面设置->常规->最大图数为1--如果你想打印一幅图的话。

  5. 设置页面设置->常规->谱图编号 为'每图从1开始'(例中)--如果你想从1开始编号。

  6. 在 页面设置->谱图中设定图的大小等内容。

  7. 在页面设置->对局信息中选中'显示棋谱标题'。

例. 我们打印一个半棋盘布局的变化图:

假设我们要从第6手挂角开始到第19手的变化，要从1开始编号，且打印在一幅图上。

我们就要在 页面设置->常规 中的选项设定如下图的值。

打印预览如下图:

标题上的数字 1 - 14 (6 -19) 意思为: 1 - 14: 图中开始和最后的行棋; (6 - 19) - 对应数值的绝对值(如，从棋谱的开局) 。


打印分支

打印布局/定式分支

你可以打印任一数据库中的布局/定式中的任一分支。

依照下面的方法就可实现:

  1. 打开布局/定式窗口，设好你要打印的变化分支的起始位置。

  2. 设置页面设置->常规->谱图类型为变化图。

  3. 设置页面设置->常规->打印到哪一手结束为变化分支结束的位置。

  4. 设置页面设置->常规->最大图数为较大的数值(如100)。

  5. 在页面设置->谱图中设定图的大小等内容。

参数页面设置->常规->从哪一手开始打印已设定为1，不能修改。

我们来考虑一个简单的例子。

我们要打印的是如下图的职业棋谱库的定式，深度为一手的所有谱图。

页面设置->常规中的参数设置如下。

页面设置->谱图 中的参数设置如下。

我们将会得到这样的打印结果:

如果不想看到初始位置的棋子的手数，不选'页面设置->谱图->第一图显示手数'即可。

看谱图的标题。

不选中'页面设置->谱图->显示谱图标题'，谱图标题将会消失。

#2是图号。不选中'页面设置->谱图->显示图号'将没有图号。

1(6) 意思是: 只有1这一手棋(绝对数为6).

a (1) [image] 意思是: 本图是'a'延伸的图1，下一手将是黑棋。不选中'页面设置->谱图->附加信息'将不输出这项内容。


搜索

你可以几种不同的方式对棋谱进行搜索:

  • 通过对局信息搜索

  1. 通过对棋谱列表的排序进行简单搜索

  2. 筛选查询

  • 通过位置搜索

  • 通过变化搜索


通过对局信息搜索

有两种搜索棋谱的方法:

  1. 设置筛选查询

  2. 对棋谱列表排序

程序对每一棋谱库的信息区中的每一列都建立了索引。

因此，你可以对棋谱列表窗口中的棋谱进行全局和局部排序。

例如，如果你想找出加藤正夫(Kato Masao)在1980年下的棋 (精装数据库) ，你要做以下操作:

  1. 打开全部或职业棋谱库。

  2. 设置全局排序为'棋手' (这意味着所有棋谱都是对棋手的名字排序，不管是黑方还是白方)。

  3. 在搜索词"Kato"，再按搜索键。

  4. 程序会找到136局加藤正夫的棋谱，并将它们筛选出来。

  5. 用鼠标点击'日期'列的标题。棋谱列表会对日期进行局部排序(仅是这样窗口)。修改'工具->选项->列表->常规->载入棋谱的最大数'的值大于136(如200)。

  6. 你就能从列表中看到加藤正夫在1980年下的两局棋谱。


信息搜索的筛选查询

你可以创建复杂的查询来对棋谱库进行筛选。

点击棋谱列表上的'筛选设置'，将打开带有筛选设定清单的窗口。

在这里可以增加、删除、编辑筛选设定。

按下'编辑'或'添加'按钮后，编辑筛选设定的窗口将打开。

我们来创建一个'加藤正夫 - 大竹英雄的棋谱'的筛选设定，有三种方法可以完成:

1.

2.

3.

执行这三个筛选设定的结果都是一样的: 0.8版的精简版有21局，0.76版的完全版有64局。

可以使用的符合：'|' - 或，'*' - 代表任何字符的通配符


通过位置搜索

这是人们最感兴趣的搜索方式。如果布局/定式棋盘是激活的，随时都可以按F7或 [image] 切换到搜索模式。

在搜索模式，编辑工具栏的所有按钮和'编辑->棋子'都变成可用的。用这些按钮就可以输入搜索位置了，其用法在编辑->棋子和 [image] 在 编辑->在棋盘设阴影中有介绍。

用 [image] 可以任意设定哪些部分包含或不包含在搜索条件中。

阴影区也可摆放黑白棋子，它们有特别的含义。

  • 空白的阴影区，很显然，代表这里可以是黑棋、白棋或者是空的。

  • 阴影区有黑棋，代表这里可以是黑棋或者是空的。

  • 阴影区有白棋，代表这里可以是白棋或者是空的。

我们试试从职业棋谱库(精简数据库)的全棋盘布局中查找下面的位置

设定好位置后，控制面板中有下面的选项:

搜索选项已经直接写明了其含义。

'清除' 按钮清除棋盘上的搜索图形。

通常情况下无需修改任何的数据，简单点'搜索'按钮来实施搜索，点'取消'按钮来取消操作。

过一会，就可看到:

按给定的位置找到两局棋谱，可选择打开其中任一局。打开棋谱时程序会根据搜索的位置自动对棋盘做转换。


通过变化搜索

你可以生成一个你感兴趣的定式或布局(全棋盘或半棋盘)的棋谱列表。

  1. 打开布局/定式窗口。

  2. 输入你感兴趣的变化。

  3. 按 [image] (布局棋谱列表)。 就这么简单!

如果仅希望从职业棋谱中查找，输入变化时，从职业棋谱布局/定式中输入。

......


查看

  1. 查看布局/定式

  2. 查看对局

  3. 查看棋谱列表.


查看布局/定式

在你查看布局/定式的同时，你可以:

  • 复制棋盘 (可从菜单中的 窗口->复制棋盘 和 窗口工具栏->复制棋盘 来实现)。

  • 创建研究棋盘(可从菜单中的 窗口->创建研究棋盘 和 窗口工具栏->创建研究棋盘 来实现)

  • 布局棋谱列表 列出与你给定的位置同样的棋谱。


查看对局

查看对局非常简单。


查看棋谱列表

打开棋谱列表的速度取决于 文件->首选项->选项->列表->载入棋谱的最大值 中的设定值。

定制棋谱列表的外观请看 选项: 列表。


从对局中打开布局

如果你打开其它SGF文件来查看棋谱，可能会对这局棋的布局有没有其它的下法感兴趣。

如果你按窗口工具栏上的 [image] ，就能打开一个新的布局窗口。在这个窗口你将看到给定对局的布局结束点。该窗口通常是全部棋谱的布局，且所有功能都可用。

这样你就能浏览你自己的棋谱的布局。


布局分析

布局分析器是研究围棋开局的有力工具。

随着数据库中棋谱数的增加，布局分析器显得更有用。

该工具既可以分析BIgo围棋助理中的棋谱，也可以分析SGF格式的其它棋谱。

被分析的棋谱放在中间的全棋盘上。在这个窗口上你可以看到整局棋谱以及从全棋盘布局数据库中可能出现的走法。八个窗口对应于主棋盘的不同部分显示可能出现的后续变化。这些窗口都可以单独浏览。

当程序不能找出某部分棋盘的后续变化时，其对应的窗口停止变化。

只要将鼠标放在9个窗口的任一窗口上，该窗口就被激活(不用点击鼠标!).

控制面板显示激活窗口的当前走法和下一手走法的统计值。

'棋盘选项工具栏' 的按钮对全部窗口同时进行操作。


提示 & 技巧

下面这些实用的提示和技巧值得关注。

  • 点击对称点

  • 修改布局/定式中的字母顺序

  • 鼠标滚轮

  • 鼠标右键

  • 多个返回参考点

  • 取消信息窗口停靠


点击对称点

在你浏览布局/定式时，无需通过对棋盘旋转或对称转换来显示对称点的位置，你只需在棋盘上你想要的位置上点击鼠标，如果该点确实是提示字母的对称点，棋盘就会自动转到合适的位置。


鼠标滚轮

如果你的鼠标有滚轮，你在任一棋盘上就可以转动滚轮来移动鼠标，包括对局、布局和定式棋盘。


鼠标右键

如果你在当前活动的棋盘上点击鼠标右键，会有这样的弹出式菜单。

你可以互换棋子颜色 (对布局和定式)、旋转棋盘或对称交换。


多个返回参考点

用于布局/定式窗口。

当最新一手棋的棋子上显示大的交叉(X)时，还有别的棋子上显示小的交叉(x)，这说明可以从别的位置也能走到当前点。单击小交叉(x)的棋子可返回到另外一路分支上。

例如:


取消信息窗口停靠

控制面板窗口包括两部分:控制面板和信息窗口。你可以将控制面板窗口拆分为两部分，通过选择菜单的视图->工具栏->'停靠信息窗' 可将它们连在一起。

还可以不同菜单就能将两个窗口连在一起，只要在信息窗口的标题上双击鼠标左键就行。

要将控制面板窗口拆分为两部分，可将鼠标光标放在放在两窗口间的线上，等到鼠标光标变成四向箭头，按住鼠标左键，就能把信息窗口放到屏幕的其它地方。


快捷键

下面是BIgo围棋助理用到的快捷键。

Ctrl+O | 打开SGF文件
Ctrl+S | 将当前活动窗口的内容保存为SGF文件(棋谱，定式，布局)
Ctrl+Alt+S | 将当前活动窗口的内容另存为新的SGF文件
Ctrl+P | 打印当前活动窗口的内容(棋谱，定式，布局)
Ctrl+C | 复制
Ctrl+A | 全选
Ctrl+L | 打开当前布局/定式的棋谱列表
Ctrl+U | 自动显示
Ctrl+D | 复制当前棋盘
Ctrl+T | 创建研究棋盘
Ctrl+Alt+H | 历史记录
Ctrl+R | 棋盘顺时针旋转90度
Ctrl+H | 水平对称交换
Ctrl+V | 垂直对称交换
Ctrl+/ | 对角线对称交换/
Ctrl+\ | 对角线对称交换\
Ctrl+J | 打开定式窗口(BIgo围棋助理完全版或BIgo定式)
F7 | 位置搜索
F1 | 帮助
Esc key | 关闭当前活动窗口(如果未锁定)
Tab key | 切换到下一窗口

用于棋盘窗口的快捷键

Home key | 到对局的开局 (布局/定式)。
End key | 到对局的终局 (布局/定式)。
Pg Up key | 到上一节点
Pg Down key | 到下一节点
Left arrow key | 后退10手
Right arrow key | 前进10手
Up arrow key | 后退一手
Down arrow key | 前进一手
Ctrl+G | 到指定点
Space key | 停招(弃权)
Ctrl+I | 棋子颜色交换(用于半棋盘和定式窗口)

用于棋谱列表的快捷键

Home key | 这些都是标准的功能键
End key |
Pg Up key |
Pg Down key |
Arrow keys |


注册

如何注册

0. 支付注册费用。你可以通过我们的网站来支付，我们的地址为 http://www.bigo.ufgo.org

1. 运行程序。

2. 选择帮助->注册。

3. 填写相关内容。

4. 按[将代码复制到剪贴板]按钮。

5. 创建一新邮件，粘贴上剪贴板中的注册信息 。

6. 将邮件发送到 bigo@ukr.net 。

7. 等待回信。我们将很快将注册码发给您。

当您收到注册码后。

1.

- 直接按[从文件读取注册码]按钮并从相应的位置选择附件中的注册码文件 RegKey.txt 。
或
- 将附件中的内容复制到剪贴板，然后按[从剪贴板读取注册码]按钮。

2. 按[确定]

3. 重新运行程序。

4. 恭喜注册成功。


新建

新建-当前版本无操作。


声音

- [image] 声音. 开/关下棋时的声音。


到指定点

Go to Move number dialog

到指定点 (Ctrl+G). 输入手数或用滑动条设定。


停招

停招(弃招). If there is a possible tenuki (pass move) in given position (this is applied to windows with joseki or half board fuseki) you can press Space and make this move. This menu item enable if tenuki possible for current position in the active window and disable if not.


Change letters order for Fuseki/Joseki Board

Type topic text here.